This thread is locked.Only browsing is available.
Top Page > Browsing
Release of OpenMX Ver.3.5
Date: 2009/09/10 01:49
Name: T.Ozaki

Hi all,

OpenMX Ver. 3.5 has been released in Sep. 2009.
The features of the release can be found in 'What's new'.

Best regards,

Taisuke Ozaki
Page: [1]

Re: Release of OpenMX Ver.3.5 ( No.1 )
Date: 2010/01/09 03:14
Name: shahryar zeynali  <>

Dear professor:
I am working Carbon nanotube & want to calculate Electronics propertis (DOS , Band structer)of carbon nanotube dopted by Boron & Nitrogen by Openmx.
I can not Optimized & calculate this system. please give input file this system.
Anyone installed Ver.3.5 on Ubuntu 9.10 successfully? ( No.2 )
Date: 2010/03/06 00:25
Name: J. Lu

The problem is there is no libg2c in the new version of Ubuntu. If someone installed it successfully, I appreciate if you can share your experience or your executable package?

Re: Release of OpenMX Ver.3.5 ( No.3 )
Date: 2010/04/09 10:27
Name: Honggyu Kim  <>

I have compiled OpenMX 3.5 with CLAPACK-3.2.1.
I followed the instruction in "Tips for installation of OpenMX"(
I downloaded clapack.tgz and compiled this first then I modified "makefile" in "openmx3.5/source" as following. (-lg2c to -lf2c)

#LIB = -L/usr/local/lib -lfftw3 -llapack -lblas -lg2c -static
LIB = -L/usr/local/lib -lfftw3 -llapack -lblas -lf2c -static

Then, I modified some files which cannot find symbol information as following.
( error message is "undefined reference to `zgemm_'" )

F77_NAME(zgemm,ZGEMM) -> f2c_zgemm

for example,

// F77_NAME(zgemm,ZGEMM)( "N","N", &nc, &ne, &ne, &a, wSHG, &nc, gs, &ne, &b, gh, &nc );
f2c_zgemm( "N","N", &nc, &ne, &ne, &a, wSHG, &nc, gs, &ne, &b, gh, &nc );

After all these, I was able to get "openmx" binary from OpenMX 3.5 on Ubuntu 9.10.
But when I run "./openmx -runtest", I get the following message while execution process.

SCF calculation at MD = 1

<MD= 1> Calculation of the overlap matrix
<MD= 1> Calculation of the nonlocal matrix
<MD= 1> Calculation of the VNA projector matrix

******************* MD= 1 SCF= 1 *******************
<Cluster> Solving the eigenvalue problem...
** On entry to DSTEVX, parameter number 3 had an illegal value
info=-3 in dstevx_

I think it can be another problem. When you try this, it may work.
I hope this can be helpful to you.
Re: Release of OpenMX Ver.3.5 ( No.4 )
Date: 2010/04/09 18:16
Name: Honggyu Kim  <>

I have found the problem that I described above.
I think CLAPACK-3.2.1 doesn't support 64-bit OS properly.
The error comes when 64-bit version of OS is installed.
It works fine with 32-bit OS.
Re: Release of OpenMX Ver.3.5 ( No.5 )
Date: 2011/05/22 04:13
Name: David

this topic is old, but for those who just face with the -lg2c problem, for me
-lgfortran instead of -lg2c and -static option removal worked on Ubuntu 10.04

Page: [1]