Top Page > Browsing
UBUNTU 22.04.3 LTS openmx 3.9 install issue
Date: 2024/01/18 15:38
Name: AHN JINWOO   <>

Dear Openmx developers/users,

I am trying to install OpenMx 3.9 version on Ubuntu 22.04.3 with intel hpc toolkit and one api base toolkit 2024.1 version.  After modifying make file, I run the command "make clean" and "make install" and get following error.
I am not able to understand the meaning of the error and how to overcome this error.
Few initial lines and final lines are appended here. Make file settings are as follows:

root@ajw-IdeaPad-3-14IAU7:/usr/local/openmx/source# make install
mpiicc -O3 -xHOST -ip -no-prec-div -qopenmp -I/opt/intel/oneapi/mkl/2024.0/include/fftw -I/opt/intel/oneapi/mkl/2024.0/include/ -I./elpa-2018.05.001 -c openmx.c
/opt/intel/oneapi/mpi/2021.11/bin/mpiicx: 1: eval: icc: not found
make: *** [makefile:222: openmx.o] Error 127

MKLROOT = /opt/intel/oneapi/mkl/2024.0
CC = mpiicc -O3 -xHOST -ip -no-prec-div -qopenmp -I/opt/intel/oneapi/mkl/2024.0/include/fftw -I/opt/intel/oneapi/mkl/2024.0/include/
FC = mpiifort -O3 -xHOST -ip -no-prec-div -qopenmp
LIB= -L${MKLROOT}/lib/intel64 -lmkl_scalapack_lp64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lmkl_blacs_openmpi_lp64 -lmpi_usempif08 -lmpi_usempi_ignore_tkr -lmpi_mpifh -liomp5 -lpthread -lm -ldl
Page: [1]

Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.1 )
Date: 2024/01/20 13:33
Name: Naoya Yamaguchi


Please be sure to do what is explained on pages 18-19 of before installing `openmx`.

Naoya Yamaguchi
Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.2 )
Date: 2024/01/22 10:07
Name: AHN JINWOO  <>

Thank you for your answer.
I followed the steps in pages 18-19 and i got result below

root@ajw-IdeaPad-3-14IAU7:~# icc --version
Command 'icc' not found, but there are 27 similar ones.
root@ajw-IdeaPad-3-14IAU7:~# ifort --version
ifort: remark #10448: Intel(R) Fortran Compiler Classic (ifort) is now deprecated and will be discontinued late 2024. Intel recommends that customers transition now to using the LLVM-based Intel(R) Fortran Compiler (ifx) for continued Windows* and Linux* support, new language support, new language features, and optimizations. Use '-diag-disable=10448' to disable this message.
ifort (IFORT) 2021.11.1 20231117
Copyright (C) 1985-2023 Intel Corporation.  All rights reserved.

root@ajw-IdeaPad-3-14IAU7:~# ifx --version
ifx (IFX) 2024.0.2 20231213
Copyright (C) 1985-2023 Intel Corporation. All rights reserved.

root@ajw-IdeaPad-3-14IAU7:~# mpirun --version
Intel(R) MPI Library for Linux* OS, Version 2021.11 Build 20231005 (id: 74c4a23)
Copyright 2003-2023, Intel Corporation.

it says ifort has been changed to ifx now and icc is still not found. I don't know why icc is not installed. I just followed the installation steps of intel oneapi base toolkit and hpc tool kit.
Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.3 )
Date: 2024/01/22 14:38
Name: chrinide  <>


An important note is that In Oneapi2024, the old intel icc/icpc compilers have been removed, so there is no mpicc/mpiicpc, you should use intelLLVM based compilers mpiicx/mpiicpx.
Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.4 )
Date: 2024/01/23 14:03
Name: jangwonjin  <>

Thank you for your advice .

I used mpiicx for CC

CC = mpiicx -O3 -xHOST -ip -qnextgen-diag -qopenmp  -I/opt/intel/oneapi/mkl/2024.0/include/fftw -I/opt/intel/oneapi/mkl/2022.1.0/include/
FC = mpiifort -O3 -xHOST -ip -no-prec-div -qopenmp
LIB= -L/opt/intel/oneapi/mkl/2024.0/lib/intel64 -lmkl_scalapack_lp64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lifcore -lmkl_blacs_intelmpi_lp64 -liomp5 -lpthread -lm -ldl -lmkl_lapack95_lp64

and i got following error.

cp openmx ../work/openmx
cp: cannot stat 'openmx': No such file or directory
make: *** [makefile:679: install] Error 1

I couldn't figure out the meaning of error.

Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.5 )
Date: 2024/01/25 12:44
Name: Hiroyuki Kawai  <>


OpenMX 3.9 cannot be compiled correctly with mpiicx included in Intel oneAPI 2024. Please use mpiicc included in Intel oneAPI 2023 for compiling OpenMX 3.9. However, for free users, Intel oneAPI 2023 is currently unavailable. If you do not have Intel oneAPI 2023, please wait for the release of OpenMX 4.0.

Hiroyuki Kawai
Re: UBUNTU 22.04.3 LTS openmx 3.9 install issue ( No.6 )
Date: 2024/01/25 20:44
Name: Naoya Yamaguchi


It can also be installed with the latest oneAPI although `makefile` need editing as follows.

CC = mpiicx -O3 -xHOST -qopenmp -fcommon -Wno-error=implicit-function-declaration -Wno-error=implicit-int -I$(MKLROOT)/include/fftw
FC = mpiifx -O3 -xHOST -qopenmp
LIB= -L${MKLROOT}/lib/intel64 -lmkl_scalapack_lp64 -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lmkl_blacs_intelmpi_lp64 -liomp5 -lpthread -lifcore -lm -ldl

Naoya Yamaguchi

Page: [1]

Thread Title (must) Move the thread to the top
Your Name (must)
E-Mail (must)
Password (used in modification of the submitted text)
Comment (must)

   Save Cookie