This thread is locked.Only browsing is available.
Top Page > Browsing
parallel running error
Date: 2015/11/07 23:24
Name: duan   <>

Follow the mannual,I have installed the parallel version openmx3.6,but when I run the test,
error occurs:
"mpirun noticed that process rank 3 with PID 13208 on node"
I installed FFTW 3.2.clapack 3.0 and openmpi-1.10 ,and the makefile is as follow:

CC = mpicc -O3 -fopenmp -Dblaswrap -I/usr/local/include
LIB = -L/usr/local/lib -lfftw3 -llapack -lblas -lg2c -lI77

and when finished with input of "mpirun -np 4 openmx Methane.dat",it says:
The calculation was normally finished. (proc= 1)

The calculation was normally finished. (proc= 2)

The calculation was normally finished. (proc= 3)

The calculation was normally finished. (proc= 0)
It seems that the 4 processes just do the same calculation.

I really need your help

Thanks a lot !

Page: [1]

Re: parallel running error ( No.1 )
Date: 2015/11/06 22:28
Name: duan  <>

what's more,another warning occurs sometimes:
** On entry to DLAGTF, parameter number 1 had an illegal value
** On entry to DLAGTS, parameter number 2 had an illegal value
Re: parallel running error ( No.2 )
Date: 2015/11/08 18:38
Name: marcindulak

You are not linking to openmpi, LIB needs to contain something like:

LIB= ... -L/usr/lib64/openmpi/lib -lmpi -lmpi_f90 -lmpi_f77

Aftert recompiling verify that openmx executable has mpi linkedin:

ldd `pathto../openmx3.6/bin/openmx` | grep mpi

The second problem, DLAGTS, suggests compatibility problems between openmx and lapack you used.
I would recommend using openblas instead, which includes lapack, also due to better performance.
One should not run netlib blas/lapack on a production system, they are only for demonstration purposes.
For reference, these are my makefile lines:

CC = mpicc -fopenmp -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic
FC = mpif90 -fopenmp -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -I/usr/lib64/gfortran/modules/openmpi
LIB = -lfftw3 -lopenblas -lgfortran -lelpa -L/usr/lib64/openmpi/lib -lmpi -lmpi_f90 -lmpi_f77

Are you really using g77 for compiling (-lg2c option)? The system must be close to 10 years old, as g77 has been replaced by gfortran in ~2006.
What is FC set to in your makefile? What is the output of:
mpicc --version
mpif90 --version

Is there a special reason you choose openmx version 3.6 instead of the latest one + latest patch?


Page: [1]