Top Page > Browsing
OpenMX in ubuntu 20.04
Date: 2020/08/14 13:56
Name: Te

Dear everyone

Does openmx supported in ubuntu 20.04 ?

previously I've been using openmx in ubuntu 18.04 and it worked fines. After i upgraded to ubuntu 20.04, i cannot run openmx as usual, even i've tried to reinstall openmx and it doesn't change anything.

when i ran openmx in terminal, they telling me i have not enough slots, which is it doesn't make any sense for me because i know i have enough slots

here is the terminal message

There are not enough slots available in the system to satisfy the 3
slots that were requested by the application:

openmx

Either request fewer slots for your application, or make more slots
available for use.

A "slot" is the Open MPI term for an allocatable unit where we can
launch a process. The number of slots available are defined by the
environment in which Open MPI processes are run:

1. Hostfile, via "slots=N" clauses (N defaults to number of
processor cores if not provided)
2. The --host command line parameter, via a ":N" suffix on the
hostname (N defaults to 1 if not provided)
3. Resource manager (e.g., SLURM, PBS/Torque, LSF, etc.)
4. If none of a hostfile, the --host command line parameter, or an
RM is present, Open MPI defaults to the number of processor cores

In all the above cases, if you want Open MPI to default to the number
of hardware threads instead of the number of processor cores, use the
--use-hwthread-cpus option.

Alternatively, you can use the --oversubscribe option to ignore the
number of available slots when deciding the number of processes to
launch.


maybe this case is such a trivial, but I don't have good knowledge about it. I'll be very happy to listen for suggestion from you all

thanks

Best regards
Te
メンテ
Page: [1]

Re: OpenMX in ubuntu 20.04 ( No.1 )
Date: 2020/08/14 17:22
Name: Naoya Yamaguchi

Hi,

This is a problem of Open MPI, not OpenMX.
You might solve it by solutions suggested in:
https://stackoverflow.com/questions/35704637/mpirun-not-enough-slots-available

As the error message says and the above thread suggests, I wonder if you will try to add an option of "--oversubscribe" into the execution command such as "mpirun".

Regards,
Naoya Yamaguchi
メンテ

Page: [1]

Thread Title (must) Move the thread to the top
Your Name (must)
E-Mail (must)
URL
Password (used in modification of the submitted text)
Comment (must)

   Save Cookie