Top Page > Browsing
OpenMX 3.8 compiling error
Date: 2017/02/13 18:58
Name: Shinya Tsukamoto   <s.tsukamoto@aist.go.jp>

Hi

I tried to compile openmx3.8 into our computer, but I found the compile
error message as follows.

In file included from openmx.c:71:
tran_prototypes.h:36: error: redefinition of typedef ‘Type_Orbs_Grid’
openmx_common.h:72: note: previous declaration of ‘Type_Orbs_Grid’ was here
make: *** [openmx.o] Error 1

Could you give me any advice?

The makefile is as follows

MKLROOT = /opt/intel/composer_xe_2011_sp1.13.367/mkl

FFTW = /home/shinya0/fftw-3.3.4
CC =/opt/intel/impi/4.1.3.045/intel64/bin/mpicc -O3 -ffast-math -fopenmp -I$(FFTW)/bin/include -I$(MKLROOT)/include
FC =/opt/intel/impi/4.1.3.045/intel64/bin/mpif90 -O3 -ffast-math -fopenmp -I$(MKLROOT)/include
LIB = -L$(FFTW)/lib/libfftw3.a -L$(MKLROOT)/lib/intel64/libmkl_scalapack_lp64.a -Wl,--start-group $(MKLROOT)/lib/intel64/libmkl_blacs_openmpi_lp64.a $(MKLROOT)/lib/intel64/libmkl_cdft_core.a $(MKLROOT)/lib/intel64/libmkl_intel_lp64.a $(MKLROOT)/lib/intel64/libmkl
_core.a $(MKLROOT)/lib/intel64/libmkl_sequential.a $(MKLROOT)/lib/intel64/libmkl_intel_thread.a -Wl,--end-group -lpthread -lm -L/usr/lib/gcc/x86_64-redhad-linux/4.4.7 -lgfortran -L/opt/intel/impi/4.1.3.045/intel64/lib/libmpi_ilp64.a


Shinya Tsukamoto
メンテ
Page: [1]

Re: OpenMX 3.8 compiling error ( No.1 )
Date: 2017/02/16 17:53
Name: Aida Palacio  <aidaph@ifca.unican.es>

Hi,

I have the same error with v3.8. I've tried installing the previous version 3.7 and it makes the following error message:

mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source -c TRAN_Set_CentOverlap_NC.c
mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source -c TRAN_Set_SurfOverlap_NC.c
mpif90 -openmp -O3 -I/usr/local/include -c elpa1.f90
mpif90 -openmp -O3 -I/usr/local/include -c solve_evp_real.f90
mpif90 -openmp -O3 -I/usr/local/include -c solve_evp_complex.f90
mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source openmx.o openmx_common.o ...............
cc: openmx.o: No such file or directory
cc: openmx_common.o: No such file or directory
.........

Could you help me, please?

Thanks,
Aida
メンテ
Re: OpenMX 3.8 compiling error ( No.2 )
Date: 2017/02/18 01:44
Name: Naoya Yamaguchi

Hi,

>mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source -c TRAN_Set_CentOverlap_NC.c
>mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source -c TRAN_Set_SurfOverlap_NC.c
>mpif90 -openmp -O3 -I/usr/local/include -c elpa1.f90
>mpif90 -openmp -O3 -I/usr/local/include -c solve_evp_real.f90
>mpif90 -openmp -O3 -I/usr/local/include -c solve_evp_complex.f90
>mpicc -openmp -O3 -I/usr/local/include -I./liberi-091216/source openmx.o openmx_common.o ...............
>cc: openmx.o: No such file or directory
>cc: openmx_common.o: No such file or directory

I think '-openmp' causes the output filename to be set 'penmp'.
If so and your compiler is 'gcc', please try to replace '-openmp' with '-fopenmp'.
メンテ

Page: [1]

Title (must) Move the thread to the top
Your Name (must)
E-Mail (must)
URL
Password (used in modification of the submitted text)
Comment (must)

   Save Cookie